e-AIのフォーラム開設

管理人のAyrです。

お待たせしました。

ルネサスサイトのe-AIツール
https://www.renesas.com/ja-jp/solutions/key-technology/e-ai/tool.html
 の公開を機に、e-AIのフォーラムも開設しました。

e-AIツールの活用方法、課題解決のアイデアなどユーザの皆様と意見交換させて頂き、

e-AIのフォーラムを盛り上げていきたいと考えています。

みなさまの投稿をお待ちしております。

  • In reply to fujita nozomu:

    ルネサスe-AI担当です。

    関連スレッドの投稿ありがとうございます。

    これからも。e-AI関連の投稿、よろしくお願いいたします。
  • お世話になっております。

    辛いPLCの仕事に時間を取られている間に、フォーラムができていたとは^^
    最終的にはマイコンへの学習機能搭載される様に期待しています。

    以前皆様に乱数seedの様々な生成方法を教えていただきましたが、
    この分野だとハード的に(?)乱数発生機能がRL78クラスでもあるといいですね。

  • e-AIトランスレータV1.0.0 ユーザマニュアルを見ながら、
    plugins配下のcaffe_windowsにある学習済みモデルをe-AIトランスレータでの変換を試しているところです。

    Configuration & TranslationダイアログのTranslateボタンを押下すると
    40%付近で以下のメッセージダイアログが表示されトランスレートに失敗してしまいます。

    ----------------------------------------------------
    Translation Status
    Translatin Failure!
    For more details, please refer the file 'translator_dd_mm_yyyy.log'
    (dd_mm_yyyy: SYstem's Date Format). in the path:
    file:/C:/Renesas/e2_studio/eclipse/
    ----------------------------------------------------

    失敗の理由をログから調査したいのですが、
    file:/C:/Renesas/e2_studio/eclipse/ にログが出力されず、
    どこに原因があるのか手がかりをつかめない状況です。

    別のPCではログも出力されており、トランスレートも成功しているのでPCの環境依存を疑っているのですが、
    'translator_dd_mm_yyyy.log'が出力されない点について、
    PCの環境設定など見直すべきポイントがございましたらご教示頂きたく存じます。
  • In reply to かず:

    かずさん、こんにちは。
    スタッフのdartsmanと申します。

    特定PCでトランスレートがうまくいかず、ログも出力されない原因について、
    2点、原因と考えられることを記載しますので、ご確認をお願いします。

    ・Windowsの確認
     e-AIトランスレータV1.0.0 ユーザーズマニュアルのP5に記載しておりますとおり、
     トランスレータが動作可能なWindowsは64bit版のみです。
     ご利用のPCのWindowsが64bit版であるかどうかをご確認ください。

    ・Windows PCへインストールしたPythonの確認
     e-AIトランスレータV1.0.0 ユーザーズマニュアルのP8に記載しておりますとおり、
     インストールするPythonには以下の条件があります。
     - バージョンが3.5.3であること
     - Windows x86-64 executable installerを使用していること
     もし、異なるバージョンのPythonや32bit版のPythonをインストールしている場合、
     一度Pythonをアンインストールしたうえで、改めてe-AIトランスレータV1.0.0
     ユーザーズマニュアル「2.3. Python3.5.3のインストール」および「2.4. Python Packageの
     インストール」を行ってください。

    以上、よろしくお願いいたします。
  • In reply to dartsman:

    岡宮と申します。私も自分のPCで、かずさんと同じ現象が発生いたします。

    念のため、システム画面(64ビット)と、コマンドプロンプトでpython3.5.3、tensorflow、他2個のパッケージがインストールされている画面を添付します。

    やはりLOGが出ないため原因がわかりません。システム要件の他に要因がありましたら、アドバイスをお願いいたします。

     

  • In reply to Okamiya Yuuki:

    岡宮さん、こんにちは。スタッフのdartsmanです。

    調査しましたところ、Pythonの3.5.3とPythonの3.6.xがインストールされている環境でもご指摘の現象になるようです。
    お手数ですが、Pythonの3.6.xがインストールされている場合、アンインストールしたうえで動作確認をお願いできますでしょうか?
    Python3.6.xはAnacondaのインストーラに含まれてインストールされていることもありますので、その点もご注意お願いします。
  • In reply to dartsman:

    かずさん、こんにちは。スタッフのdartsmanです。

    上記の岡宮さんへのリプライに記載しました通り、Pythonの3.6.xのインストールが原因となっているケースもありましたので、問題が解決していない場合、こちらのご確認もよろしくお願いします。
  • In reply to dartsman:

    dartsmanさん、回答をありがとうございます。
    Anaconda(Python 3.6.1)をアンインストールした結果、トランスレートに成功しました。

    ちなみに、Tensorflowを使う際、コマンドプロンプト起動時にPythonパスが通っていないのは不便なので、パスを通してトランスレートを試してみたのですが、一応成功しました。
    現状ではインストール時に「パスを通さない」が正解なのですが、Tensorflow使用時の環境は維持したいので、パスを通しても問題ない条件など示されているといいですね。
  • dartsmanさん、岡宮さん
    ありがとうございます。

    インストールされていたpythonのバージョンが3.5だったようで、3.5.3にアップデートしたところ
    無事、translator_03_08_2017.logが出力されるようになりました。

    トランスレートにはまだ成功できていませんが、ログを頼りに頑張ってみます。
  • In reply to かず:

    かずさん、こんにちは。スタッフのdartsmanです。

    logファイルですが、こちらでも一度内容確認したいと思っています。
    お手数ですが、下記のURLより「開発環境・開発ツールの技術に関する
    お問合せはこちら」をクリックして、お問い合わせフォームからlogファイルを
    送付いただけないでしょうか?
    ※お問い合わせフォームの一番下にファイルを添付して送付する機能があります。

    URL: www.renesas.com/.../contact.html

    お手数をおかけしますが、よろしくお願いします。
  • dartsman さん。

    ありがとうございます。
    お言葉に甘えさせていただき、
    件名「e-AIトランスレータV1.0.0でcaffe_windowsにある学習済みモデルをトランスレートするとエラーが発生する件」にて
    開発環境・開発ツールの技術に関するお問合せにlogファイルを送付させて頂きました。

    恐れ入りますがよろしくお願い致します。
  • In reply to かず:

    かずさん、コンタクトセンタへのご連絡ありがとうございます。
    スタッフのdartsmanです。

    早速いただいたログを確認しました。

    恐らく、もともとPythonの3.5をインストールされていて、3.5に対しては
    Python Packageをインストールされていたのだと思いますが、
    今回、Pythonの3.5.3にアップデートされたので、Pythonの3.5.3に
    対しても、Python Packageのインストールを改めて行っていただくことで
    解決する可能性があると思いました。

    ということで、以下の手順にてPython3.5.3に対してPython Packageのインストールを
    改めて実施お願いします。
    [インストール手順]
    e-AIトランスレータのマニュアル(資料番号:R20UT4135JJ0100)の
    「2.4. Python Packageのインストール」

    お手数をおかけしますが、ご確認のほど、よろしくお願いいたします。